I suggest you ...

Support Single Sign-On when REMOTE_USER environment variable contains user@domain

I am using mod_auth_kerb for SPNEGO based SSO. This sets the REMOTE_USER to user@domain.

I have worked around this by adding the following lines to wpmuLdapSSOGetUsername()

if (strpos($username, '@') !== FALSE) {
$username = substr($username, 0, strpos($username, '@'));
}

Please consider including this in the codebase

6 votes
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
Dave Marshall shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

0 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base